Teachstone, a Public Benefit Corporation - MyTeachstone platform - video playback not working for many customers – Incident details

MyTeachstone platform - video playback not working for many customers

Resolved
Operational
Started over 1 year agoLasted about 1 hour

Affected

Video Services

Operational from 2:55 PM to 4:16 PM

Updates
  • Resolved
    Resolved

    Kaltura believes they have resolved this issue - we will monitor for additional updates from them before we resolve this incident.

    Thank you for your patience and understanding.

  • Identified
    Update

    Kaltura has mitigated the issue and is in the process of restoring video playback functionality across their platform.

    Video service functionality will be restored soon.

  • Identified
    Update

    Kaltura has identified the root cause for this problem and is actively working to correct it.

  • Identified
    Update

    Kaltura is continuing to investigate and correct the issue with video playback; as of this message they have not yet identified a fix for the widespread issues with their video player.

    Video playback continues to not work throughout our platform at this moment in time.

  • Identified
    Identified

    Hi,

    Our video playback vendor, Kaltura, has identified an issue with video playback that is affecting a wide number of their customers; we've confirmed that many Teachstone users are experiencing issues with video playback throughout our platform.

    Kaltura has informed us they have identified the cause of this issue and are working to resolve it as quickly as possible.

    I will update again once we hear updates from Kaltura on their progress towards a resolution.